ПрограммыПоддержкаКупитьПартнерам
Закрыть окно

Запрос в техподдержку

Обработка данных...
Ваше имя:*


Название организации:


Электронная почта:*


Программа, которую вы используете:*

Тема обращения:*


Серийный номер:*

Серийный номер можно посмотреть в свидетельстве на программу или в лицензионном договоре.

Суть вопроса, проблемы:*

Примечание. Консультации по бесплатной версии программы осуществляются на форуме техподдержки.

Поиск по базе знаний:
Например, обновить программу
Бухгалтерия
Бухгалтерия
Торговый склад
Торговый склад
Зарплата и кадры
Зарплата и кадры
ЖКХ
ЖКХ
Автомойка
Автомойка
Платформа разработки
Платформа разработки

Торговый склад

Информация загружается...

Перенос собственных разработок из 1-ой во 2-ую платформы

Самая распространенная задача при переходе с 1-ой на 2-ую версию – перенос собственных разработок. Чтобы выгрузить собственную разработку, не связанную с какой-то стандартной программой, достаточно выбрать пункт меню Файлы | База данных | Архивировать и указать “Все компоненты программы”. Программа сохранит настройку и все данные в PAK-файле. Чтобы перенести это все во 2-ую версию, надо подключиться к пустой базе данных EMPTY.GDB, зайти в пункт меню Установка | Обновление версии и указать на сохраненный PAK-файл для его загрузки. После появления сообщения “Операция успешно завершена. Необходимо перезапустить программу.” настройка будет загружена!

Однако чаще всего речь идет о каком-то модуле, дописанном в одной из стандартных программ (ИП: Бухгалтерия, ИП: Бухгалтерия + Торговый склад и т.п.). В этом случае процесс перехода на 2-ую версию разбивается на два этапа: надо перенести данные стандартной программы (ИП: Бухгалтерия, ИП: Бухгалтерия + Торговый склад и т.п.) и перенести дополнительный модуль (включая и разработки, и имеющиеся данные в дополнительных журналах). Эти два этапа независимы. Можно сначала перенести данные стандартной настройки, а потом дополнительный модуль, или наоборот. Порядок переноса данных стандартных программ описан в отдельной инструкции по переходу с 1-х версий. В этой же статье рассматривается перенос дополнительного модуля (настройки) и его данных.

выгрузка 1При переносе модуля (настройки) в этом случае используется не пункт меню Файлы | База данных | Архивировать, а пункт меню Сервис | Установка | Дистрибутив, т.к. надо дополнительно вычленить те элементы (журналы, бланки, отчеты и т.д.), которые относятся именно к нему, а не к стандартной версии. Для этого надо сделать следующее:

Зайти в пункт меню Сервис | Установка | Дистрибутив. Запустится мастер выгрузки настройки. На первой закладке надо указать название настройки – произвольную строку (хотя она будет потом отображаться во 2-ой версии в меню Справка | О программе) и версию (см. рис.)

выгрузка 2После нажатия “Далее >” откроется закладка с параметрами выгрузки. Здесь указывается путь к файлу конфигурации (PAK-файлу, в котором сохранится выгружаемая настройка).

Не помешает поставить флажок “Запомнить модель дистрибутива” – если потребуется повторная выгрузка позже, например, по причине того, что забыли указать какие-то выгружаемые бланки или отчеты, то не надо будет потом заново устанавливать все другие опции – достаточно будет выбрать путь к модели дистрибутива в графе “Название” в самом начале мастера.

выгрузка 3Далее, надо указать состав выгружаемого дистрибутива. Это можно сделать, нажав кнопку “Состав”. Здесь, надо нажать “Сброс” для очистки содержимого выгрузки. После этого устанавливаются флажки:

  • “Меню, пользователи, функции журналов”
  • Нужные бланки в разделе “Бланки документов”.
  • Нужные бланки в разделе “Отчеты”.
  • Нужные типовые операции в разделе “Типовые операции”
  • Нужные библиотеки в разделе “Библиотеки”
  • В разделах “Служебные данные” и “Данные” необходимо отметить журналы, относящиеся к модулю (настройки)

Опции “Определения”, “Реквизиты”, “Множества” и “Оглавления” можно, как ставить, так и нет. Если их много, то лучше поставить, однако после переноса настройки во 2-ую версию, убрать лишние, не относящиеся к переносимому модулю (настройке). Рекомендуется все-таки не ставить эти опции, а перенести нужные определения, реквизиты, множества и оглавления вручную.

После нажатия “Далее >” появится завершающая создание дистрибутива закладка. На ней ничего не надо менять. Нажимается клавиша “Готово”.

После того как PAK-файл создан, запускается Инфо-Предприятие 2-ой версии, вход осуществляется под Администратором.

Если множества не сохранялись в PAK-файле, то их надо добавить вручную перед загрузкой.

выгрузка 4Также, перед загрузкой надо сохранить главное меню администратора, для того чтобы потом объединить пункты главного меню, относящиеся к импортируемуму модулю и пункты меню стандартной настройки. Для этого надо зайти в Администрирование | Настройка меню (см.рис).

А затем в Файлы | Экспорт в и сохранить меню под произвольным именем, например ADMIN.MNU.

Далее производится загрузка модуля, для этого надо зайти в пункт меню Установка | Обновление версии и указать на сохраненный PAK-файл. Необходимо дождаться сообщения “Операция успешно завершена. Необходимо перезапустить программу”.

выгрузка 5После того как модуль будет загружен, надо настроить главное меню. Для этого надо зайти в Администрирование | Настройка меню, удалить все пункты меню, кроме тех, которые относятся к перенесенному модулю.

Затем зайти в Файлы | Экспорт в, сохранить меню, относящееся к загруженному модулю под каким либо именем, например MODUL.MNU. Потом, не закрывая редактора меню, зайти в Файлы | Импорт из и загрузить сохраненное ранее меню Администратора из файла ADMIN.MNU. При загрузке выбрать вариант “Добавить новые пункты меню” для объединения пунктов меню модуля (настройки) и стандартных пунктов меню Администратора.

выгрузка 6Пункты стандартного меню Администратора добавятся вконец. Надо выстроить меню так, как удобно (см.рис).

После этого выстраивается меню и для других интерфейсов. Чтобы сделать это, например, для интерфейса “Бухгалтерия”, надо выбрать его в редакторе меню и зайтем зайти в Файлы | Импорт из и загрузить сохраненное ранее меню модуля из файла MODUL.MNU.

После перехода надо проверить:

  1. Поля с подстановкой значения из другого журнала. Если запись подставлялась из журнала или справочника стандартной программы (ИП: Бухгалтерия, ИП: Бухгалтерия + Торговый склад и т.п.) в 1-ой версии, то она не перенеслась. Надо отыскать наиболее подходящий для ссылки справочник новой программы (Комплекса)
  2. Корректность переноса значений множеств
  3. Работа обработчиков, бланков, отчетов, типовых операций может быть нарушена в случае, если они использовали журналы из стандартной программы (ИП: Бухгалтерия, ИП: Бухгалтерия + Торговый склад и т.п.) в 1-ой версии. В этом случае их необходимо подправить.
  4. Добавить по-необходимости нужные определения, реквизиты и оглавления.

Если какие-то компоненты модуля или содержимое журналов модуля неправильно перенеслись, то в процессе подстройки модуля под 2-ую версии их можно перенести по-отдельности:

  • Журналы – с помощью файлов с расширением JRN
  • Бланки – зайдя в конкретный бланк и выбрав импорт из файла с расширением FRM – для замены существующего бланка или зайдя в список бланков и выбрав импорт из файла с расширением FRM – для добавления бланка из 1-ой версии.
  • Отчеты – зайдя в конкретный отчет и выбрав импорт из файла с расширением REP – для замены существующего отчета или зайдя в список отчетов и выбрав импорт из файла с расширением REP – для добавления отчета из 1-ой версии.
  • Библиотеки функций – зайдя в конкретную библиотеку, выбрав тип файлов “Файл библиотеки функций ИП1” и импортировав файл с расширением LIB или создав новую библиотеку с последующим импортом из библиотеки 1-ой версии
  • Библиотеки типовых операций – зайдя в конкретную библиотеку, выбрав тип файлов “Библиотека типовых операций ИП1” и импортировав файл с расширением LIB или создав новую библиотеку с последующим импортом из библиотеки 1-ой версии.

Рекомендуется ознакомиться со статьей “Перенос разработок из версий 1.x” встроенной справки для более подробного ознакомления с особенностями переноса настроек.